Update Cable For Smooth Flite and Smart Bus RRS

Pacific RC Jets

$24.95 

Sorry, this item is out of stock

Share:


 

Allows owners of Smooth Flite ARXL, Smooth Flite Spektrum, Smart Bus RRS ARXL to update to the latest version. 

Requires loader version 1.2 or 1.3. Contact Booma RC for details if unsure.

Please note this product is NOT compatible with Smart Bus Extreme, Smart Bus Extreme 3S or Smart Bus Elite.